Схема интернета – Идеальная домашняя сеть или «сам себе злобный перфекционист» / Qrator Labs corporate blog / Habr

Содержание

подключаем все устройства и расширяем диапазон Wi-Fi

Наверх
  • Рейтинги
  • Обзоры
    • Смартфоны и планшеты
    • Компьютеры и ноутбуки
    • Комплектующие
    • Периферия
    • Фото и видео
    • Аксессуары
    • ТВ и аудио
    • Техника для дома
    • Программы и приложения
  • Новости
  • Советы
    • Покупка
    • Эксплуатация
    • Ремонт
  • Подборки
    • Смартфоны и планшеты
    • Компьютеры
    • Аксессуары
    • ТВ и аудио
    • Фото и видео
    • Программы и приложения
    • Техника для дома
  • Гейминг
    • Игры
    • Железо
  • Еще
    • Важное

Как построить сеть с нуля в офисе (160+ компьютеров, 20+ IP камер)? — Хабр Q&A

spoilerВсем привет!
Думаю, многие бы много отдали начинающие сисадмины и эникеи такие как я , чтобы им достался такой «проект» который достался мне, и на нем набираться знаний и опыта!
Думаю, это хороший шанс научиться чему-то новому)

На вопрос директору, почему не отдадут IT на аутсорс, говорит что им надо растить свои кадры)
Вот такой колхоз, парни) Работает- не трогай)

О себе:
Дёргающийся эникей, желающий много учиться и познавать, перечитавший Танненбаумов, Олифером и их подобным, пересмотревший уйму видео и мануалов по сетям, серверам, виртуализации, но не имел дело с практикой. Все время работал с железом и ремонтом периферии. Варил оптику. Знаком с Mikrotik и Windows server, Linux и Cisco в глаза не видел.


Есть 3-х этажный офис в маленьком городке.
Сеть:
Сеть состоит из +-160 компов + 20 IP камер, компы заведены в одноранговую сеть 192.168.x.x , никаких AD и доменов, все сидят в одном широковещательном домене в workgroup, нет никаких vlan, никаких розеток, ни одного умного свитча, вся сеть построена на мыльницах tp-link воткнутых друг в друга «гирляндой», про иерархическую модель сети тут никто не слышал, комутационных шкафов, патч панелей, маркировок и прочего тоже нет, общая захламленность((
Wi-Fi состоит из автономных AP стоящих на разных этажах)
Из хорошего один Mikrotik, настроенный наверно по quick set который является шлюзом, dns и dhcp сервером!
Сервер:
Есть tower сервер windows 2012,raid 10, все дела, на котором крутиться 1с, к какой подключаються все пользователи по rdp. 1с обслуживает «аутсорс» фирма, все хорошо, кроме одного… сервер стоит в помещении «сисадмина» который все это строил и он там заправляет картриджи)
Рабочие станции:
Толстые клиенты, 30% компов еще на xp, остальные 7!

Чего я хочу:
Так как хочется все сделать по уму, а хороший сисадмин строит все надежно и безопасно, а не затыкает дыры, хочу ваших советов и поддержки.
У меня уже примерно нарисовалась картина что и как должно быть, но хочется услышать альтернативное мнение, план действий т.д!
Думаю строить сеть с нуля, прокладывать новые линии.

Вопросы:
Какое оборудование (модели) ставить на уровень доступа, распределения?
Как делать — 4 коммутатора на все устройства (в шкафу), или же по одному на этажах и центральный в серверную? Как нарезать vlan? По этажам? По кабинетах?
Первый вариант хорош тем, что все под рукой, но в случае добавления новых пользователей, надо будет тянуть кабель от серверной, расшивать патч панель и короба и.т.д , второй – лучшая масштабируемость, но знаю что никаких свитчей в комнатах, где люди сидят, разумеется, быть не должно. Так и не знаю делать ли интернет розетки или нет)
Ах да, принтеры. На сервере каждому пользоваелю добавлены расшаренные их принтеры, (через принтеры и факсы), проброс принтеров по rdp не работает, что не страшно в даном случае, но что будет если я захочу напечатать текст на свой принтер вне этой сети, а допустим из дома? в сетевом окружении я не найду свой компютер, как быть)

Спасибо!

Компьютерная сеть в квартире своими руками


Вступление

Задача создания компьютерной сети в отдельно взятой квартире до банальности проста. Компьютерная сеть в квартире, прежде всего, должна обеспечить качественное устойчивое интернет соединение всех компьютеров в квартире. Вторая задача компьютерной сети, которая как мне кажется, для квартиры не актуальна, обеспечить связь между компьютерами квартиры для обмена данными.

Теория

В теории компьютерную сеть в квартире лучше называть локальной компьютерной сетью с доступом в Интернет. Существуют две принципиально различные технологии связи между компьютерами одной локальной сети.

  • Первая технология это связь по проводам, называемая LAN технология, аббревиатура от Local Area Network.
  • Вторая технология, как вы уже поняли, это беспроводная технология связи, называемая WLAN (Wireless Local Area Network).

В быту беспроводная технология передачи данных  по радиочастотному каналу, более знакома под названием Wi-Fi (вай-фай). Хотя для беспроводной связи компьютеров, даже в пределах квартиры, более правильно использовать термин WLAN, а не Wi-Fi.

Справедливости ради нужно заметить, что существует технология передачи данных через электрические сети. Называется такая технология Powerline. Однако характеристики Powerline не позволяют рекомендовать её, даже, как дополнительную связь между рабочими машинами в пределах квартиры.

домашний интернет

Что лучше LAN или WLAN?

Вопрос, что лучше LAN или WLAN компьютерная сеть в квартире не сосем корректен. По скорости соединения и качеству сигнала, правильно сделанная проводная сеть LAN превосходит беспроводное соединение.

Однако Wi-Fi связь, даже в пределах одной квартиры удобнее и не требует, практических работ по монтажу сетевых линий.

На практике и это, скорее всего, порекомендует вам любой Интернет провайдер, проводная (кабельная) компьютерная сеть должна стать основной в вашей квартире, а беспроводная сеть, должна выступать, как дополнительная возможность. Почему это так, чуть ниже.

Проектирование

В пределах квартиры, фраза проектирование компьютерной сети, несколько преувеличена. Достаточно понять принцип работы локальной сети, чтобы нарисовать её схему для своей квартиры.

Во-первых, подавляющее большинство пользователей, не делают локальную компьютерную сеть в квартире, только ради обмена данными между устройствами в квартире. Как правило, компьютерная сеть в квартире является следствием подключения квартиры к Интернет, через услуги местного или глобального Интернет провайдера.

В таком варианте WLAN квартиры, можно сравнить с квартирной электропроводкой. Есть точка внешнего подключения к местной компьютерной сети, от которой вам нужно сделать разводку компьютерной сети квартиры или сделать возможность подключения локальных машин к этой точке.

Будем считать точку входа отправной в устройстве локальной сети квартиры. В отличие от электропроводки отключение внешнего источника, не выведет локальную сеть из строя и связь между рабочими станциями в пределах квартиры останется в рабочем состоянии.

Проводная компьютерная сеть в квартире своими руками

Повторюсь, LAN компьютерная сеть в квартире является самой надежной, а по скорости работы очень удобной в работе.

Проводная или кабельная компьютерная сеть в квартире, вместе с телефонной сетью, называют слаботочной. Несмотря на слабые токи этой сети, прокладка кабелей слаботочной сети должна проводиться по правилам. О них в статье Как самостоятельно проложить слаботочные кабели в квартире: слаботочные сети в жилых помещениях.

Подключение компьютера к локальной сети осуществляется через разъёмы стандарта, именуемого в быту RJ-45LAN, а у профессионалов разъём 8P8C. Подключить компьютер можно напрямую, установив разъём RJ-45 на кабель слаботочной сети. Или установить специальную компьютерную розетку, которая также называется RJ-45.

RJ-45RJ-45 вилкарозетки компьютерныерозетки компьютерные: встроенная, накладная

Хочу именно здесь сделать маленькое отступление. Оно будет важно для дальнейшего повествования.

В компьютерных сетях, выполняемых кабелем витая пара, необходимо согласовывать сопротивление на обоих концах кабеля. Это значит, что вы не можете сделать розетку RJ-45 проходной. Каждая линия кабельной компьютерной сети должна начинаться и заканчиваться устройством.

Например, компьютер роутер или компьютер коммутатор, или компьютер патч. Кстати, когда мы говорим про подключение компьютера, мы имеем виду подключение сетевой карты, которая должна входить в компьютерную сборку. Отсутствие такой карты делает невозможным использовать компьютер в компьютерной сети.

Кабель для компьютерной сети квартиры

Для устройства компьютерной сети квартиры используют кабель называемый «витая пара». Витая пара это электрический кабель с медными одно проволочными жилами покрытых изоляцией и общей оболочкой. Некоторые виды кабеля витая пара имеют защитные экраны и другие улучшения конструкции. О них подробно в статье: Кабели слабых токов.

Характерной особенностью кабелей витая пара, отразившейся в его названии, является парное расположение жил кабеля, которые свиты между собой.

Фото кабеля витая пара

Такое «витое» расположение жил кабеля упрощает подключение кабеля, которое называют распиновка. Для информации, существует прямая и обратная распиновки кабеля витая пара. Первая используется для подключения конечных устройств к распределителю, например, компьютер к роутеру. Вторая используется для связи аналогичных устройств, например, двух компьютеров.

Для компьютерной сети квартиры достаточно 4 парного кабеля витая пара, тип UTP (без экрана). Лучше с экраном от помех (тип FTP). Марка кабеля выбирается по вашим возможностям.

Зачем нужен роутер

Как я сказал выше, отправной точкой компьютерной сети квартиры считаем кабель интернет провайдера, введенный в вашу квартиру. Задача компьютерной сети квартиры распределить общий доступ между девайсами квартиры.

Решает эту задачу, основной прибор локальной сети, называемый роутер или маршрутизатор. Задача роутера обеспечить подключение N-количество LAN линий квартиры для доступа к одной внешней линии связи.

Как вы уже поняли, с одной стороны, роутер подключается к внешней компьютерной линии. С другой стороны к нему подключаются локальные компьютерные линии квартиры LAN/1-LAN/N.

Фото кабеля витая пара роутер проводной Фото кабеля витая пара роутер комбинированный Фото кабеля витая пара роутер wi-fi-игровой

Так как роутер это не только разветвитель, а сложное устройство выполняющее массу основных и дополнительных задач, для его питания требуется электропитание 220В. Мощность роутера слишком мала, чтобы говорить об особых требованиях для электропроводки розетки роутера.

Стоит отметить, что при большом количестве устройств в квартире, и нехватке LAN портов роутера, делается масштабирование компьютерной сети при помощи так называемых коммутаторов или switch. Для выполнения ряда дополнительных задач, коммутаторам также требуется электропитание.

коммутаторы в сети

Вывод по LAN

Итак,  кабельная компьютерная сеть в квартире своими руками, потребует от вас:

  • Проконтролировать проведение внешней линии Интернет от провайдера;
  • Определить расположение девайсов (компьютеров) квартиры которые нужно связать в сеть;
  • Установить в этих местах розетки rj-45 для подключения;
  • Проложить кабель витая пара от каждой розетки до места установки роутера. Ближайший компьютер к роутеру, по умолчанию, будет настройщиком роутера;
  • Подключить кабель к розеткам и коннекторам rj-45 для роутера;
  • Сетевые платы подключить к розеткам или кабелю через коннекторы;
  • Роутер подключить к входящему кабелю;
  • Провести настройки роутера;
  • Проверить работу всех устройств квартиры.

WLAN квартиры

Если вы не хотите заниматься кабельной проводкой и вам достаточно характеристик беспроводной сети, можно приобрести НЕ проводной, а беспроводной роутер. В этом случае, к каждому компьютеру нужно приобрести Wi-Fi адаптер. Выбрать место установки роутера, согласно планировке вашей квартиры, чтобы рабочие машины не попали в мертвые зоны роутера.

Настроить роутер и использовать компьютерную сеть квартиры без проводов.

компьютерную сеть квартиры без проводов

Разумный выбор

Будет разумно, не останавливаться на ограниченных вариантах, выбирая только проводной или только беспроводной роутер. Это неразумно.

Разумным вариантом выбрать роутер проводной с функцией Wi-Fi подключения. Такие роутеры уже давно находятся в широкой продаже и пользуются заслуженной популярностью.

Общий вывод

Компьютерная сеть в квартире, может быть выполнена по проводной, беспроводной или комбинированной технологии. Так как подключение роутера и его настройку проводят сотрудники интернет провайдера, то компьютерная сеть в квартире своими руками это вполне выполнимая задача. Важно правильно провести распиноку кабеля, о чём в следующей статье.

©ehto.ru

Похожие посты:


Поделиться ссылкой:

Карта подводного интернета 2014 от TeleGeography / Habr

Мировая карта «подводного интернета» от компаний TeleGeography и 8banks, которые специализируется на сборе и обработке данных телекома в финансовом секторе:



На карте отображены оптоволоконные кабели, которые проходят по дну океанов, соединяя страны. Конечно же, есть еще масса оптоволоконных соединений по суше, но они не отображены на карте.
Пол Бродски, аналитик TeleGeography, комментируя карту, объяснил: «Подавляющее большинство интернет-трафика путешествует по оптоволоконным кабелям. Многие люди думают, интернет-соединения проходят через спутники, но это не так. Они проходят по этим подводным кабелям.Компании, которые прокладывают эти оптоволоконные кабели, размещают на судне огромную катушку и отправляют корабль в плавание из страны А в Б, разматывая катушку по пути. То есть кабель в буквальном смысле просто лежит на дне океана. И лишь на подходе к берегу кабель закапывается в траншею.

Именно эти кабели дают нам скорость связи в милисекунды между Нью-Йорком и Лондоном. Самый большой риск для данных кабелей это рыбацкие лодки, и корабли, который бросают якорь. Иногда бывают стихийные бедствия, как землетрясения. Но если кабель поврежден, то трафик просто перенаправляется на другой кабель. Бродски говорит, что управляющие и прокладывающие компании, постоянно мониторят состояние кабелей и при любой неисправности отправляются в море, вытаскивают проблемный участок и заменяют его.

Как вы можете видеть в карте, большинство стран, которые имеют доступ к морю, подключены к данным каналам. И в будущем стоит ждать увеличения количества соединений. По словам Бродски: «Каждая страна, у которой есть одно подключение, хочет еще 2-ое и 3-ее». Ниже увеличенные участки карты:

Оригинал Business Insider.
Пост о карте за 2013 год тут. TeleGeography github.

Как устроен интернет? — Интересно знать

14.04.2019 20:51 532

В современном мире интернет прочно вошёл в жизнь многих людей. С его помощью можно общаться, находясь далеко друг от друга, получать разную информацию, смотреть фильмы и слушать музыку. Многие из вас, ребята, уже знакомы с интернетом.
А вот как устроен интернет?
В сеть интернет вы заходите с помощью компьютера. В каждом компьютере есть специальная сетевая карта, которая отвечает за то, чтобы на компьютере работал интернет.

К сетевой карте в специальный разъём подключается проводок, называемый патчкордом. Этот патчкорд соединяет компьютер со специальным устройством — коммутатором. К коммутатору может быть подлючено много компьютеров. Каждый компьютер подключен к коммутатору в специальный порт. Если вы заходите в интернет по беспроводной сети (Wi-Fi), то тогда к коммутатору подключается ваш роутер.

Коммутатор собирает информацию (данные) с каждого компьютера, соединяет её вместе (в один поток) и передаёт по одному патчкорду далее на следующее устройство, которое называется маршрутизатор. Название коммутатор происходит от слова коммутация, то есть он коммутирует (соединяет, собирает) данные с каждого компьютера, чтобы передать их дальше.

Если вы хотите отправить письмо по электронной почте своим друзьям, то вашему компьютеру нужно знать информацию о том, где находятся их компьютеры. Для этого были придуманы специальные адреса, которые есть у каждого компьютера. Они называются MAC-адрес и IP-адрес (мак-адрес и айпи-адрес). MAC-адрес состоит из цифр и букв. Он находится в сетевой карте каждого компьютера и устанавливается уже на заводе. IP-адрес состоит только из цифр. Компьютер получает его автоматически через специальный сервер, либо он назначается специалистом (сетевым инженером). MAC-адрес и IP-адрес на каждом компьютере всегда разные. Кроме компьютеров, MAC-адрес и IP-адрес есть у каждого маршрутизатора и каждого коммутатора.
 Название маршрутизатор происходит от слова маршрут. В сети интернет находится много маршрутизаторов, которые расположены в разных местах, и стараются передавать данные друг другу по более короткому маршруту.

Это можно сравнить с тем, как вы едете на машине из одного места в другое, выбирая более короткий путь. Получив данные от коммутатора, маршрутизатор передаёт их другим маршрутизаторам, которые находятся ближе к компьютеру ваших друзей. Маршрутизатор всегда знает IP-адрес соседнего (ближайшего) к нему маршрутизатора. Получив данные, самый ближний к компьютеру ваших друзей маршрутизатор, передаёт их к уже упомянутому нами коммутатору (только не тому, который ближе к вашему компьютеру, а к другому, компьютеру ваших друзей). Коммутатор принимает эти данные. Поскольку он знает MAC-адрес каждого компьютера, который к нему подключен, то он и передаёт их в виде вашего сообщения.
Если вы, ребята, заходите на какой-нибудь сайт, то набирая его название, вы попадаете на сервер, где этот сайт находится.
Север — это почти тот же компьютер, очень похожий по своим функциям, только выглядит он иначе (у него нет монитора и клавиатуры).

На серверах хранятся разные сайты и большое количество всякой другой информации. Серверы расположены в стойках, которые находятся в специальных помещениях — дата-центрах, где за ними следят люди и поддерживается нужная температура.

Названия сайтов (их ещё называют доменными именами)придуманы для нас с вами, чтобы их можно было легче запомнить. Компьютер же видит название сайта в виде таких же цифр. Поэтому, когда вы вводите адрес сайта, то попадаете на специальный сервер, который переводит его название в IP-адрес нужного сервера, на котором находится сайт, который вам нужен.


Как создавать понятные логические (L3) схемы сети / Habr

Cамая большая проблема, с которой я сталкиваюсь при работе с сетями предприятий — это отсутствие чётких и понятных логических схем сети. В большинстве случаев я сталкиваюсь с ситуациями, когда заказчик не может предоставить никаких логических схем или диаграмм. Сетевые диаграммы (далее L3-схемы) являются чрезвычайно важными при решении проблем, либо планировании изменений в сети предприятия. Логические схемы во многих случаях оказываются более ценными, чем схемы физических соединений. Иногда мне встречаются «логически-физически-гибридные» схемы, которые практически бесполезны. Если вы не знаете логическую топологию вашей сети, вы слепы. Как правило, умение изображать логическую схему сети не является общим навыком. Именно по этой причине я пишу эту статью про создание чётких и понятных логических схем сети.

Какая информация должна быть представлена на L3-схемах?

Для того, чтобы создать схему сети, вы должны иметь точное представление о том, какая информация должна присутствовать и на каких именно схемах. В противном случае вы станете смешивать информацию и в итоге получится очередная бесполезная «гибридная» схема. Хорошие L3-схемы содержат следующую информацию:
  • подсети
    • VLAN ID (все)
    • названия VLAN’ов
    • сетевые адреса и маски (префиксы)

  • L3-устройства
    • маршрутизаторы, межсетевые экраны (далее МСЭ) и VPN-шлюзы (как минимум)
    • наиболее значимые серверы (например, DNS и пр.)
    • ip-адреса этих серверов
    • логические интерфейсы

  • информацию протоколов маршрутизации

Какой информации НЕ должно быть на L3-схемах?

Перечисленной ниже информации не должно быть на сетевых схемах, т.к. она относится к другим уровням [модели OSI, прим. пер.] и, соответственно, должна быть отражена на других схемах:
  • вся информация L2 и L1 (в общем случае)
  • L2-коммутаторы (может быть представлен только интерфейс управления)
  • физические соединения между устройствами

Используемые обозначения

Как правило, на логических схемах используются логические символы. Большинство из них не требуют пояснений, но т.к. я уже видел ошибки их применения, то позволю себе остановиться и привести несколько примеров:
  • Подсеть, представленная как трубка или линия:

  • VRF или другая не известная точно зона представляется в виде облака:


Какая информация необходима для создания L3-схемы?

Для того, чтобы создать логическую схему сети, понадобится следующая информация:
  • Схема L2 (или L1) — представление физических соединений между устройствами L3 и коммутаторами
  • Конфигурации устройств L3 — текстовые файлы либо доступ к GUI, и т.д.
  • Конфигурации устройств L2 — текстовые файлы либо доступ к GUI, и т.д.
Пример

В данном примере мы будем использовать простую сеть. В ней будут присутствовать коммутаторы Cisco и МСЭ Juniper Netscreen. Нам предоставлена схема L2, также как и конфигурационные файлы большинства представленных устройств. Конфигурационные файлы пограничных маршрутизаторов ISP не предоставлены, т.к. в реальной жизни такую информацию ISP не передаёт. Ниже представлена L2-топология сети:

А здесь представлены файлы конфигурации устройств. Оставлена только необходимая информация:

asw1

!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.11 255.255.255.128
!
ip default-gateway 192.168.10.1


asw2

!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.12 255.255.255.128
!
ip default-gateway 192.168.10.1


asw3

!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.13 255.255.255.128
!
ip default-gateway 192.168.10.1


csw1

!
vlan 200
name in-transit
!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/4
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/5
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/6
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 200
ip address 10.0.0.29 255.255.255.240
standby 1 ip 10.0.0.28
!
interface vlan 210
ip address 192.168.0.2 255.255.255.128
standby 2 ip 192.168.0.1
!
interface vlan 220
ip address 192.168.0.130 255.255.255.128
standby 3 ip 192.168.0.129
!
interface vlan 230
ip address 192.168.1.2 255.255.255.128
standby 4 ip 192.168.1.1
!
interface vlan 240
ip address 192.168.1.130 255.255.255.128
standby 5 ip 192.168.1.129
!
interface vlan 250
ip address 192.168.10.2 255.255.255.128
standby 6 ip 192.168.10.1
!
ip route 0.0.0.0 0.0.0.0 10.0.0.17


csw2

!
vlan 200
name in-transit
!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/4
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/5
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/6
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 200
ip address 10.0.0.30 255.255.255.240
standby 1 ip 10.0.0.28
!
interface vlan 210
ip address 192.168.0.3 255.255.255.128
standby 2 ip 192.168.0.1
!
interface vlan 220
ip address 192.168.0.131 255.255.255.128
standby 3 ip 192.168.0.129
!
interface vlan 230
ip address 192.168.1.3 255.255.255.128
standby 4 ip 192.168.1.1
!
interface vlan 240
ip address 192.168.1.131 255.255.255.128
standby 5 ip 192.168.1.129
!
interface vlan 250
ip address 192.168.10.3 255.255.255.128
standby 6 ip 192.168.10.1
!
ip route 0.0.0.0 0.0.0.0 10.0.0.17


fw1

set interface ethernet0/1 zone untrust
set interface ethernet0/1.101 tag 101 zone dmz
set interface ethernet0/1.102 tag 102 zone mgmt
set interface ethernet0/2 zone trust
set interface ethernet0/1 ip 10.0.0.1/28
set interface ethernet0/1 manage-ip 10.0.0.2
set interface ethernet0/1.101 ip 10.0.0.33/28
set interface ethernet0/1.102 ip 10.0.0.49/28
set interface ethernet0/2 ip 10.0.0.17/28
set interface ethernet0/2 manage-ip 10.0.0.18
set vrouter trust-vr route 0.0.0.0/0 interface ethernet0/1 gateway 10.0.0.12


fw2

set interface ethernet0/1 zone untrust
set interface ethernet0/1.101 tag 101 zone dmz
set interface ethernet0/1.102 tag 102 zone mgmt
set interface ethernet0/2 zone trust
set interface ethernet0/1 ip 10.0.0.1/28
set interface ethernet0/1 manage-ip 10.0.0.3
set interface ethernet0/1.101 ip 10.0.0.33/28
set interface ethernet0/1.102 ip 10.0.0.49/28
set interface ethernet0/2 ip 10.0.0.17/28
set interface ethernet0/2 manage-ip 10.0.0.19
set vrouter trust-vr route 0.0.0.0/0 interface ethernet0/1 gateway 10.0.0.12


outsw1

!
vlan 100
name Outside
!
vlan 101
name DMZ
!
vlan 102
name Mgmt
!
interface GigabitEthernet1/0
description To-Inet-rtr1
switchport mode access
switchport access vlan 100
!
interface GigabitEthernet1/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet1/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet1/4
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 102
ip address 10.0.0.50 255.255.255.240
!
ip default-gateway 10.0.0.49


outsw2

!
vlan 100
name Outside
!
vlan 101
name DMZ
!
vlan 102
name Mgmt
!
interface GigabitEthernet1/0
description To-Inet-rtr2
switchport mode access
switchport access vlan 100
!
interface GigabitEthernet1/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet1/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet1/4
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 102
ip address 10.0.0.51 255.255.255.240
!
ip default-gateway 10.0.0.49

Сбор информации и её визуализация

Хорошо. Теперь, когда мы имеем всю необходимую информацию, можно приступать к визуализации.
Процесс отображения шаг за шагом

  1. Сбор информации:
    1. Для начала откроем файл конфигурации (в данном случае ASW1).
    2. Возьмём оттуда каждый ip-адрес из разделов интерфейсов. В данном случае есть только один адрес (192.168.10.11) с маской 255.255.255.128. Имя интерфейса — vlan250, и имя vlan 250 — In-mgmt.
    3. Возьмём все статические маршруты из конгфигурации. В данном случае есть только один (ip default-gateway), и он указывает на 192.168.10.1.

  2. Отображение:
    1. Теперь давайте отобразим информацию, которую мы собрали. Во-первых, нарисуем устройство ASW1. ASW1 является коммутатором, поэтому используем символ коммутатора.
    2. Нарисуем подсеть (трубку). Назначим ей имя In-mgmt, VLAN-ID 250 и адрес 192.168.10.0/25.
    3. Соединим ASW1 и подсеть.
    4. Вставляем текстовое поле между символами ASW1 и подсети. Отобразим в нём имя логического интерфейса и ip-адрес. В данном случае имя интерфейса будет vlan250, и последний октет ip-адреса — .11 (это является общей практикой — отображать только последний октет ip-адреса, т.к. ip-адрес сети уже присутствует на схеме).
    5. Также в сети In-mgmt есть другое устройство. Или, как минимум, должно быть. Нам ещё неизвестно имя этого устройства, но его IP-адрес 192.168.10.1. Мы узнали это потому, что ASW1 указывает на этот адрес как на шлюз по-умолчанию. Поэтому давайте отобразим это устройство на схеме и дадим ему временное имя «??». Также добавим его адрес на схему — .1 (кстати, я всегда выделяю неточную/неизвестную информацию красным цветом, чтобы глядя на схему можно было сразу понять, что на ней требует уточнения).


На этом этапе мы получаем схему, подобную этой:

Повторите этот процесс шаг за шагом для каждого сетевого устройства. Соберите всю информацию, относящуюся к IP, и отобразите на этой же схеме: каждый ip-адрес, каждый интерфейс и каждый статический маршрут. В процессе ваша схема станет очень точной. Убедитесь, что устройства, которые упомянуты, но пока неизвестны, отображены на схеме. Точно так же, как мы делали ранее с адресом 192.168.10.1. Как только вы выполните всё перечисленное для всех известных сетевых устройств, можно начать выяснение неизвестной информации. Вы можете использовать для этого таблицы MAC и ARP (интересно, стоит ли писать следующий пост, рассказывающий подробно об этом этапе?).

В конечном счёте мы будем иметь схему наподобие этой:

Заключение

Нарисовать логическую схему сети можно очень просто, если вы обладаете соответствующими знаниями. Это продолжительный процесс, выполняемый вручную, но это отнюдь не волшебство. Как только у вас есть L3-схема сети, достаточно нетрудно поддерживать её в актуальном состоянии. Получаемые преимущества стоят приложенных усилий:
  • вы можете планировать изменения быстро и точно;
  • решение проблем занимает гораздо меньше времени, чем до этого. Представим, что кому-то нужно решить проблему недоступности сервиса для 192.168.0.200 до 192.168.1.200. После просмотра L3-схемы можно с уверенностью сказать, что МСЭ не является причиной данной проблемы.
  • Вы можете легко соблюдать корректность правил МСЭ. Я видел ситуации, когда МСЭ содержали правила для трафика, который никогда бы не прошёл через этот МСЭ. Этот пример отлично показывает, что логическая топология сети неизвестна.
  • Обычно как только L3-схема сети создана, вы сразу заметите, какие участки сети не имеют избыточности и т.д. Другими словами, топология L3 (а также избыточность) является такой же важной как избыточность на физическом уровне.

Отправить ответ

avatar
  Подписаться  
Уведомление о